Oracle10g 安装 Failed to Transfer Directory “/u01/app/crs/inventory”

搜索MOS文章:

AIX: PRKC-1073 : Failed to Transfer Directory “/u01/app/crs/inventory” to Any of the Given Nodes (文档 ID 1314406.1)

解决方法:

1. 在rac所有节点上执行以下命令

chmod -R u+w /opt/app/oracle/product/10.2.0/crs_1/inventory/Templates/*

2. 在rac的主节点上,也就是执行安装的节点上执行以下命令

(cd /opt/app/oracle/product/10.2.0/crs_1/inventory && /usr/bin/find ./* -depth -print | /bin/cpio -oacEignore)|/usr/bin/ssh -o FallBackToRsh=no -o PasswordAuthentication=no -o StrictHostKeyChecking=yes -o NumberOfPasswordPrompts=0 rac2 “(cd /opt/app/oracle/product/10.2.0/crs_1/inventory &&/bin/cpio -idmuc)”

IX: PRKC-1073 : Failed to Transfer Directory “/u01/app/crs/inventory” to Any of the Given Nodes (文档 ID 1314406.1)    转到底部

In this Document

Symptoms

Cause

Solution

References

APPLIES TO:

Oracle Server – Enterprise Edition – Version: 10.2.0.4 to 10.2.0.5 – Release: 10.2 to 10.2

IBM AIX on POWER Systems (64-bit)

SYMPTOMS

When applying patchset 10.2.0.x on top of CRS 10.2.0.1, the following error message is in installAction*.log

WARNING: Error while copying directory /u01/app/crs/inventory with exclude file list ‘/tmp/OraInstall2011-03-23_10-40-10AM/installExcludeFile.lst’ to nodes ‘racdb2’. [PRKC-1073 : Failed to transfer directory “/u01/app/crs/inventory” to any of the given nodes “racdb2 “.

Error on node racdb2:null]

As per SRVM traces, the following command failed:

(cd /u01/crs/oracle/product/10.2.0/crs/inventory && /usr/bin/find ./* -depth -print | /bin/cpio -oacEignore)|/usr/bin/ssh -o FallBackToRsh=no -o PasswordAuthentication=no -o StrictHostKeyChecking=yes -o NumberOfPasswordPrompts=0 coredb2 “(cd /u01/crs/oracle/product/10.2.0/crs/inventory &&/bin/cpio -idmuc)”

The error message:

[Thread-96] [6:5:7:409] [StreamReader.run:65] ERROR>cpio: 0511-007 Cannot create Templates/install/rootupgrade; errno is 13.

CAUSE

Write permission is missing on some files created by base release 10.2.0.1:

<crs_home>/inventory/Templates/install/root*

This issue is described in unpublished bug 8555018 which is duplicate of unpublished bug 6727474.

This problem only applies to patchset 10.2.0.4 and 10.2.0.5 on AIX.

SOLUTION

1.Install CRS 10.2.0.1

2.Execute the following command on ALL remote nodes:

$ chmod -R u+w <CRS_HOME>/inventory/Templates/*

3.Apply patchset 10.2.0.4/10.2.0.5

If you had patchset already installed, please manually transfer these files as following. Replace <CRS_HOME> and <node_name> with actual value.

— on all remote nodes

$ chmod -R u+w <CRS_HOME>/inventory/Templates/*

— on local node

$ (cd <CRS_HOME>/inventory && /usr/bin/find ./* -depth -print | /bin/cpio -oacEignore)|/usr/bin/ssh -o FallBackToRsh=no -o PasswordAuthentication=no -o StrictHostKeyChecking=yes -o NumberOfPasswordPrompts=0 <node_name> “(cd <CRS_HOME>/inventory &&/bin/cpio -idmuc)”

for example:

(cd /u01/crs/oracle/product/10.2.0/crs/inventory && /usr/bin/find ./* -depth -print | /bin/cpio -oacEignore)|/usr/bin/ssh -o FallBackToRsh=no -o PasswordAuthentication=no -o StrictHostKeyChecking=yes -o NumberOfPasswordPrompts=0 coredb2 “(cd /u01/crs/oracle/product/10.2.0/crs/inventory &&/bin/cpio -idmuc)”



以下文章点击率最高

Loading…


发表评论

电子邮件地址不会被公开。 必填项已用*标注